Version 5.0

This section contains all getting started articles for the version 5.x branch of EasyQuery for .NET Core.

Please note if you have a project for .NET Framework (version 4.x or earlier) - please look at the articles in Version 3.x section.

Getting started for ASP.NET Core + Razor pages

Here we describe how to add EasyQuery to your ASP.NET Core application with MVC or Razor Pages views. Prerequisites You have an ASP.NET Core version 2.1+ project with MVC views (or Razor pages) Your application uses Entity Framework Core to work with the database. (NB: it's possible to use EasyQuery without EF Core as well but for the sake of simplicity we will not consider other cases here).

Getting started with EasyQuery in ASP.NET Core + Angular project

Here we describe how to add EasyQuery widgets to your ASP.NET Core + Angular project. Prerequisites You have an ASP.NET Core (version 2.1+) project with Angular (6.0+) on the client-side. We suppose the project was created using a standard ASP.NET Core template ( dotnet new angular ) but it's not a requirement.

Getting started for ASP.NET Core + Vue project

This article describes how to use EasyQuery library in Vue.js project with ASP.NET Core backend.

Getting started for ASP.NET Core + React project

This article describes how to use EasyQuery library in React.js project with ASP.NET Core backend.