API reference 5.X (deprecated)